View unanswered posts | View active topics It is currently Wed Apr 23, 2014 11:06 pm



Reply to topic  [ 14 posts ] 
LEX SV823A - works 
Author Message

Joined: Wed Feb 25, 2004 6:06 pm
Posts: 74
Post LEX SV823A - works
I can confirm that the Lex SV823A motherboard with on-board video capture works using Redhat 9.0 and ZoneMinder 1.18 - 1.19.1

The SV823A contains 4 BT878 chips, each one capable of 25fps.

As the board is a VIA C3 with VIA chipset, Linux is a bit of a pain to set up - eventually I'll finish writing up my experiences and post them on the web!


Thu Apr 15, 2004 5:39 pm
Profile

Joined: Wed Aug 18, 2004 7:51 am
Posts: 4
Post 
Hy, unclerichy

I'm very intersting by this board, could you post more on this :

frame per second and size :
I think 4 x 640x480 x 25fps is impossible with a C3 @ 1GHz ?
Motion detection in this format too ?

Wath is realistiq whith an C3 @1GHz ?
4x 320x200 15fps in motion detection ? in full record ?

Thanks

Guillaume


Wed Aug 18, 2004 7:58 am
Profile

Joined: Wed Feb 25, 2004 6:06 pm
Posts: 74
Post 
I'm currently running the following configuration:

SV823A
512MB RAM
Samsung SpinPoint 160GB ATA-133
Redhat 9.0
Apache 1.3.29
SSH
No keyboard, no mouse.

All housed in a custom cabinet along with a USR wireless bridge, wireless camera receiver, a six-way power strip, the motherboard power brick and four plug-in PSUs for the cameras and wireless bridge.

The MySQL server is a separate FreeBSD 4.8 box on an EPIA V8000 board accessed via the wireless bridge.

I've two active cameras:

1) B&W
Capturing at 528x432 in Greyscale
1 Inclusive zones

2) Colour/B&W with Infrared
Capturing at 352x288 in RGB24
2 Inclusive zone

Both cameras are locked at 10 fps until an alarm occurs though they tend to hover at 8.33 fps.

Typical load-average runs at around 0.5 and climbs to around 1.0 when running viewing an event or in Montage view.

The only performance issues I've had are when something fills up a large portion of the image on camera one, at which point it sometimes drops frames. I've tried using the frame daemon (zmf) but that never actually manages to write anything to disk.

The bottleneck is definitely the processor as the SV823A is capable of 25fps per input, giving a theoretical 100fps total. I should imagine that 4 x 320x200 at 15fps might be pushing it a bit.

Overall I'm happy with the results though - the board is quite costly but it's a great all-in one solution.

Hope this helps.


Thu Aug 19, 2004 10:05 pm
Profile

Joined: Wed Aug 18, 2004 7:51 am
Posts: 4
Post 
I've just receved this board with 4 conexan 848 A and make test this week.
I'll post results.


Mon Aug 23, 2004 9:26 pm
Profile

Joined: Wed Feb 25, 2004 6:06 pm
Posts: 74
Post 
I was in the process of writing up my experiences though I haven't got around to finishing it yet. You're welcome to take a look:

http://athome.hunter13.com/linux/rh9sv823a.html

EDIT: The above link has since gone, here's a copy -> http://web.archive.org/web/200411090212 ... v823a.html


Last edited by unclerichy on Sun Jan 01, 2006 11:55 pm, edited 1 time in total.



Mon Aug 23, 2004 9:56 pm
Profile

Joined: Wed Feb 25, 2004 6:06 pm
Posts: 74
Post 
guiguid wrote:
I've just receved this board with 4 conexan 848 A and make test this week.
I'll post results.


Any news on this?


Sun Oct 03, 2004 2:44 pm
Profile
Site Admin
User avatar

Joined: Wed Jul 09, 2003 3:07 pm
Posts: 5221
Location: Bristol, UK
Post 
What kind of performance do you get from these boards?

I had a quick play with one and it was ok, but I've also installed onto just regular Lex boards and they seem to struggle with multiple cameras at higher (ie 10+) frame rates.

Phil,


Sun Oct 03, 2004 5:40 pm
Profile ICQ YIM WWW
User avatar

Joined: Thu Jul 10, 2003 7:00 pm
Posts: 240
Post 
i want more info.. how much power this use?

is powered by only 12v. how many amps it use in normal use?
the prossesor heat up?

so by the info you give. this sistem can hable 4 cameras 320*240 at 2fps with no problems!

_________________
Fernando


Sun Oct 03, 2004 9:05 pm
Profile

Joined: Wed Feb 25, 2004 6:06 pm
Posts: 74
Post 
phil:

I'm currently running two cameras

Camera 1:

Colour
352 x 288
3 Zones

Camera 2:

Grayscale
528x432 (ie. 1.5x regular size)
1 Zone

Both are running Modect and they will happily sit at 10fps when running a Montage view.

Frame rate is entirely dependant on the amount of movement in the image - camera 1 can usually keep up at around 9fps. Camera 2, being of a larger size, tends to be around 5 fps. I may drop camera 2 to 352x288 as there are a few interlacing artefacts visible.

Typical load with only the console window open on another PC is 0.66.

I suspect the lowish frame rates are caused by an number of things:

1) The mySQL server is a separate machine accessed over an 802.11g wireless link from my garage.
2) When encoding JPGs for events it's still analysing background images at 10fps or so.
3) The processor itself (a 1GHz VIA C3) is roughly equivalent to a P-III 500.

fernando:

I can't say how much power it's using at the moment - at some point I'll stick my power meter on it. As for 4 cameras at 2fps - I can't see that being a problem.

The reason I chose this setup is that the board, hard disk, wireless access point, five PSUs (3 camera, 1 for the WAP and 1 for the board), wireless camera receive and four-way surge protected power strip all fit in a box 45cm x 38cm x 11cm.

Here's a rendering of it: http://www.hunter13.com/cctv.jpg (27KB)


Mon Oct 04, 2004 7:25 pm
Profile
User avatar

Joined: Thu Jul 10, 2003 7:00 pm
Posts: 240
Post 
nice.. i see a video receptor there. is a 1.2ghz? since 2.4 can interfiere with the AP.

i will find the way a can get one of those mothers in here.. ARGENTINA>
i can trade it for a good juicy pece of beff. :wink:

_________________
Fernando


Mon Oct 04, 2004 8:20 pm
Profile

Joined: Wed Feb 25, 2004 6:06 pm
Posts: 74
Post 
Yep, it's a 1.2GHz model. I don't really use it much as the reception is quite poor and is easily blocked by walls.


Mon Oct 04, 2004 10:28 pm
Profile

Joined: Thu Apr 07, 2005 3:55 am
Posts: 3
Post ANy updates..
HI

I was googling for this epia/lex solution experiences, and I found only this one?

I am planning to build a full system, with 4 camera's and ZM with mysql, www server etc all hosted on one box(mini ITX size) which I can safely hide/mount on a wall.

Do you think we have a better solution as of June 2005, than this lex system. I would like to have a fanless system, however I guess this doesn't seem to be possible at this moment.

Anyways back to the point, what is your experience with the system which I guess you are now having for almost a year ?

Regards
Ghat


Fri May 20, 2005 6:35 pm
Profile

Joined: Wed Feb 25, 2004 6:06 pm
Posts: 74
Post 
Sorry for the delay in replying - too many things going on at the moment.

My experience has been fairly positive overall with only one significant problem: overlapping cameras (ie. two pointing at the same area, but from different positions) can cause problems as there isn't enough CPU power to motion detect and generate jpegs for two simultaneous streams. Recently I've switched on the frame server option which has improved matters quite considerably. Tweaking the camera positions has also helped matters so the overlap is smaller and hence less chance of simultaneous triggers.

Both hardware and software reliability has been great - the system runs 24/7 in a custom enclosure and has never had to be rebooted. The only down time has been due to area-wide power failures, with the system recovering without my intervention once power was back on.

One word of advice - if you're going to mount your system to a wall then make sure that any moving parts (fans, hard disks etc.) are dampened otherwise you may find the vibrations travel through the walls. Not a problem during the day but in the dead of night I found that I could hear the hard disk seeks being transmitted through my bedroom walls!

If I did it again I would definitely look at a P4 based solution in order for their to be enough power under the hood to process more cameras. Any solution using VIA C3 and Eden processors is going to have to be very highly tuned to eek out that last drops of performance. The Lex board is quite expensive for what it is but that's the price you pay for having a system with a small footprint.

Hope this helps.


Wed Jun 22, 2005 10:27 pm
Profile

Joined: Wed Feb 25, 2004 6:06 pm
Posts: 74
Post 
It's been over 5 years and I'm pleased to report the SV823A is still going strong. Apart from the occasional local power cut (and one replacement PSU - see later) it's run 24x7x365 for every one of those days.

In that time it's enclosure has been fastened to my garage wall and has endured temperatures down to -6 oC and as high as 30 oC and has never skipped a beat. RedHat was replaced by Gentoo a few years ago and I'm sat with ZM 1.22.3 because I doubt that the CPU can handle anything beyond that.

The 12v external PSU was replaced when it died one day and thanks to those nice people at www.linitx.com a replacement was obtained incredibly quickly after my initial e-mail to them.

The wireless bridge got the push in favour of a homeplug device and the mySQL server was brought on board rather than being accessed over the network.

This last week it's been moved to a custom 2U 19" rack enclosure and now sits with all my other rack-mounted kit up in my loft. Time will tell how it likes the increased heat but the enclosure is spacious and with some metal working of the power drill and dremel variety it's suitably ventliated and benefits from a wired network connection.

Since the original post I've added a second B&W camera and total power consumption for the entire system sits at a steady 30 watts.


Thu Jun 11, 2009 5:45 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 14 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group