View unanswered posts | View active topics It is currently Sat Nov 29, 2014 10:36 am



Reply to topic  [ 22 posts ]  Go to page 1, 2  Next
HELP - FFMPEG and Low Quality Jpeg 
Author Message

Joined: Tue Jul 03, 2007 7:50 pm
Posts: 19
Post HELP - FFMPEG and Low Quality Jpeg
Hello all...

I had that to reduce the quality of the images that are recorded in to be able to record more time. However for my surprise I can't generate videos with ffmpeg…

Code:
ffmpeg -f image2 -i %03d-capture.jpg -s 320x240 video.mpg


Code:
[mjpeg @ 0xb7e0b4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e0b4e8]dqt: 16bit precision
[mjpeg @ 0xb7e0b4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e0b4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e0b4e8]dqt: 16bit precision
[mjpeg @ 0xb7e0b4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e0b4e8]decode_sos: index(0) out of components
[image2 @ 0xb7eeb980]Could not find codec parameters (Video: mjpeg)
%03d-capture.jpg: could not find codec parameters



If I return to the configuration standard of the ZoneMinder (ZM_JPEG_FILE_QUALITY = 70) I obtain to generate videos with no erros!

Somebody has some idea?

Thanks


Last edited by diogojorge on Thu Jul 05, 2007 12:46 pm, edited 2 times in total.



Tue Jul 03, 2007 7:57 pm
Profile

Joined: Tue Jul 03, 2007 7:50 pm
Posts: 19
Post 
Nobody???

please test and see if the same error happens, and later reply here!

Thanks


Wed Jul 04, 2007 1:03 pm
Profile

Joined: Tue Jul 03, 2007 7:50 pm
Posts: 19
Post 
It's impossible that only me have this problem...

I only ask to anyone test this for me:

Downgrade the value of ZM_JPEG_FILE_QUALITY to 20, record some thing then try to generate a video with ffmpeg... then tell me that this process work fine or not!

that's all

Thanks


Fri Jul 06, 2007 6:32 pm
Profile

Joined: Sun Jun 03, 2007 3:54 pm
Posts: 23
Post 
Quote:
It's impossible that only me have this problem...

I only ask to anyone test this for me:

Downgrade the value of ZM_JPEG_FILE_QUALITY to 20, record some thing then try to generate a video with ffmpeg... then tell me that this process work fine or not!

that's all

Thanks


Sorry to tell you but i set ZM_JPEG_FILE_QUALITY to 20 and then generated a mpg video with no problem

poor quality but viewable


Sat Jul 07, 2007 1:32 am
Profile

Joined: Tue Jul 03, 2007 7:50 pm
Posts: 19
Post 
Hum... :(

What is your plataform?

Which type of camera you used? Network? Analogic?

Thanks


Mon Jul 09, 2007 11:47 am
Profile

Joined: Sun Jun 03, 2007 3:54 pm
Posts: 23
Post 
Platform is Intel PII 600 X2
512 MB Memory
MoBo is VIA chipset
SCSI disk system

running a Bttv 4 port capture card
all cameras are 1/3" CCD from Vista and Grundig and COP
and this is running the current LIVECD ZoneMinder 1.22.3 installed to Harddisk.

Hope that helps

PS thought i should add all cams are running 640x480 with a Load: 0.81


Mon Jul 09, 2007 6:50 pm
Profile

Joined: Tue Jul 03, 2007 7:50 pm
Posts: 19
Post 
I continue with problems.

I set quality to 20 and I can't generate films from the recorded images.

Already tried in two distributions: Slackware and Debian and I did not have success in none of them.

Somebody could help me send me the ffmpeg package (.tar.bz) that you guys using ...

log:
Code:
# ffmpeg -i %03d-capture.jpg teste.mpg
FFmpeg version SVN-r8002, Copyright (c) 2000-2007 Fabrice Bellard, et al.
  configuration: --prefix=/usr --enable-shared --enable-libogg --enable-libmp3lame --enable-gpl
  libavutil version: 49.3.0
  libavcodec version: 51.33.0
  libavformat version: 51.10.0
  built on Feb 17 2007 13:39:44, gcc: 3.4.6
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components
[image2 @ 0xb7f3d980]Could not find codec parameters (Video: mjpeg)
%03d-capture.jpg: could not find codec parameters


Thanks


Mon Jul 09, 2007 8:20 pm
Profile
User avatar

Joined: Tue Jul 03, 2007 11:05 pm
Posts: 19
Location: Salt Lake, UT, US
Post 
You could try installing ffmeg from source :
Code:
svn checkout svn://svn.mplayerhq.hu/ffmpeg/trunk ffmpeg
cd ffmpeg/
./configure
make
make install
make install-libs

This will make sure that all neccessary components (libs and whatnot) are out there.

_________________
Ammaross Danan


Mon Jul 09, 2007 11:01 pm
Profile

Joined: Tue Jul 03, 2007 7:50 pm
Posts: 19
Post 
Nothing AmmarossDanan....

neilk, the same error happens in livecd of zoneminder, you REALLY Downgrade the value of ZM_JPEG_FILE_QUALITY to 20, record some thing then try to generate a video with ffmpeg?

Can I send to you the jpegs that i try to generate a video?

Than you can see if yours ffmpeg generate the video...

Thanks


Tue Jul 10, 2007 2:15 pm
Profile

Joined: Sun Jun 03, 2007 3:54 pm
Posts: 23
Post 
diogojorge,

have you tried to generate any other type of video , other than a .mpg

you "may" have a codec problem !!

try and generate a .avi,wmv,mpeg etc and see if you can

1.Video Generation Parameters
2.Video Format
3. select Type


if you can get a video out of ZM using another type of video format then i would say you do have a codec problem

Neil :idea:


Tue Jul 10, 2007 6:47 pm
Profile

Joined: Tue Jul 03, 2007 7:50 pm
Posts: 19
Post 
neilk,

I try all formats... and the same problem persist

The problem is that in liveCD of ZoneMinder 1.22.3 this exactly problem occurs, if you will be able to test would been thankful, and if the test OK then tell me yours platform and distribution.

The problem happens in cameras analogical and cameras IP.

Therefore I SUPPOSE that is a bug of ZoneMinder

Thanks


Tue Jul 10, 2007 7:35 pm
Profile
User avatar

Joined: Tue Jul 03, 2007 11:05 pm
Posts: 19
Location: Salt Lake, UT, US
Post 
It is odd that this occurs for you even with the LiveCD. What hardware are you trying to run on?

I would guess the problem resides with this error:
Quote:
[mjpeg @ 0xb7e5d4e8]dqt: 16bit precision
[mjpeg @ 0xb7e5d4e8]mjpeg: unsupported coding type (c1)
[mjpeg @ 0xb7e5d4e8]decode_sos: index(0) out of components

_________________
Ammaross Danan


Tue Jul 10, 2007 11:50 pm
Profile

Joined: Tue Jul 03, 2007 7:50 pm
Posts: 19
Post 
Test 1:
DELL OptiPlex GX620
Processador Intel® Pentium® D 915 Hyper Threading on
512 MB RAM DDR2, 667MHz (2DIMM)
HD 250GB Serial ATA, 3.0Gb/s
VGA Intel® Graphics Media Accelerator (GMA) 3000
Chipset: INTEL

Test 2:
Intel(R) Pentium(R) 4 CPU 2.80GHz
512 MB RAM DIMM
VGA [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter
Chipset: SIS

AmmarossDanan, what hardware are you run ZM? You made the test placing ZM_JPEG_FILE_QUALITY in 20, to record some thing and later trying to generate the video... then tell me if works!

Thanks


Wed Jul 11, 2007 1:06 pm
Profile

Joined: Sun Jun 03, 2007 3:54 pm
Posts: 23
Post 
try and encode manualy as below:

First, rename your pictures to follow a numerical sequence. For example, img1.jpg, img2.jpg, img3.jpg,... Then you may run:

ffmpeg -f image2 -i img%d.jpg /tmp/a.mpg

Notice that `%d' is replaced by the image number.

`img%03d.jpg' means the sequence `img001.jpg', `img002.jpg', etc...

The same logic is used for any image format that ffmpeg reads.
if this works then maybe you will be better asking about your error at this site

http://ffmpeg.mplayerhq.hu/


Wed Jul 11, 2007 8:03 pm
Profile

Joined: Tue Jul 03, 2007 7:50 pm
Posts: 19
Post 
I tried this and also it did not works

thanks and the problem persist!


Wed Jul 11, 2007 8:15 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 22 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group