View unanswered posts | View active topics It is currently Thu Jul 24, 2014 8:19 pm



Reply to topic  [ 7 posts ] 
How do I run "zmu -d <device> -q -v" against an IP camera?? 
Author Message

Joined: Tue Sep 18, 2012 2:50 am
Posts: 4
Post How do I run "zmu -d <device> -q -v" against an IP camera??
Hi all -

I've got a problem with an IP camera and getting
past the "red x" problems I'm hoping someone can help with.

Question first:
Why can I not see images in the main camera window, see them in any event I try to view, but if I export them, the exported 'index.html' has a viewer that works just fine?

Now the details:


I'm running a Foscam FI8918W, following the instructions at:
http://www.zoneminder.com/wiki/index.php/Foscam_FI8918W
I am using it in snapshot.cgi mode, because I am on wireless, and
another site I was reading indicated that massive problems occured
with network traffic when trying to stream from it vs framegrab.

System is Ubuntu 12.04, fully patched.
ffmpeg 0.8.3

I've checked out:
http://www.zoneminder.com/wiki/index.ph ... leshooting
and tried to follow the steps carefully, so as not to waste anyone's time here.

I can see my camera in xawtv and in guvcview cheese, no problems.
It also works fine in it's own browser, etc etc.

So I got the camera loaded and working just fine, capturing events in Mocord.

But I cannot view images in the brower (IE9, IE8, Chrome, Firefox, on Windows, on Ubuntu)
Upon consulting troubleshooting, the suggestion was:
"run zmu -d..." to see if your device is supported.

Nothing in the syntax in the manual or any other Googleing
indicates what the syntax for <device> would be when you have an IP camera, and it's device is something other than /dev/video0 as everyone's example shows.

Mine being an IP camera, it is of course _not_ a USB device connected to the computer.... and has no /dev/ entry at all.


Tue Sep 18, 2012 3:45 am
Profile

Joined: Sat Jul 28, 2012 9:30 pm
Posts: 96
Post Re: How do I run "zmu -d <device> -q -v" against an IP camer
What do you mean you can't view images? Are you sure you have set up the monitor parameters correctly? Do you see live stream in zoneminder and have problem accessing captured events (btw mocord records constantly but has motion detection too. modect records only on motion)? In case you have set up authentication with hash, try plain authentication as a temporary fix.


Tue Sep 18, 2012 7:16 am
Profile

Joined: Tue Sep 18, 2012 2:50 am
Posts: 4
Post Re: How do I run "zmu -d <device> -q -v" against an IP camer
I mean that I cannot see images:

This screen should show images down below the line of squares, I think:
Attachment:
event-screen.jpg
event-screen.jpg [ 33.63 KiB | Viewed 729 times ]


So I'm unable to see video.

I switched the Foscam to using
a Source of:
/videostream.cgi?user=zm&pwd=getimages

It was
/snapshot.cgi?user=zm&pwd=watchcam

Neither works.

I'd be glad to check the monitor parameters-
I followed directions in the Wiki on setting up Foscams.

But I didn't know how to specify a Foscam for "zmu -d <device> -q -v"
Plenty of examples of /dev/video0, if I were running USB.

No examples of how to use zmu to check on an IP cam..


I'm also getting these in the logs, if that helps..

This is with "videostream.cgi" in use.
2012-09-18 21:54:46.440220 zmdc 6517 ERR 'zma -m 1' exited abnormally, exit status 11 zmdc.pl
2012-09-18 21:54:46.437758 zma_m1 7090 INF Got signal 11 (Segmentation fault), crashing zm_signal.cpp 73
2012-09-18 21:54:42.574970 zma_m1 7090 INF In mode 5/1, warming up zma.cpp 101
2012-09-18 21:54:42.521230 zmdc 7090 INF 'zma -m 1' started at 12/09/18 21:54:42 zmdc.pl
2012-09-18 21:54:42.519600 zmdc 6517 INF 'zma -m 1' starting at 12/09/18 21:54:42, pid = 7090 zmdc.pl
2012-09-18 21:54:42.402301 web_php 1608 ERR socket_sendto( /tmp/zm/zms-955475s.sock ) failed: No such file or directory /usr/share/zoneminder/includes/functions.php 2322
2012-09-18 21:54:42.369270 zmwatch 6560 INF Restarting analysis daemon for Foscam_FI8918W, time since last analysis 6 seconds (1348019682-1348019676) zmwatch.pl
2012-09-18 21:54:36.314030 zmdc 6517 ERR 'zma -m 1' exited abnormally, exit status 11 zmdc.pl
2012-09-18 21:54:36.311564 zma_m1 7086 INF Got signal 11 (Segmentation fault), crashing zm_signal.cpp 73
2012-09-18 21:54:32.412897 zma_m1 7086 INF In mode 5/1, warming up zma.cpp 101
2012-09-18 21:54:32.363670 zmdc 7086 INF 'zma -m 1' started at 12/09/18 21:54:32 zmdc.pl
2012-09-18 21:54:32.363670 zmdc 6517 INF 'zma -m 1' starting at 12/09/18 21:54:32, pid = 7086 zmdc.pl
2012-09-18 21:54:32.231380 zmwatch 6560 INF Restarting analysis daemon for Foscam_FI8918W, time since last analysis 7 seconds (1348019672-1348019665) zmwatch.pl


and this is with 'snapshot.cgi" in use
2012-09-18 22:00:14.043450 zmdc 6517 ERR 'zma -m 1' exited abnormally, exit status 11 zmdc.pl
2012-09-18 22:00:14.040950 zma_m1 7299 INF Got signal 11 (Segmentation fault), crashing zm_signal.cpp 73
2012-09-18 22:00:08.779526 web_php 5497 ERR socket_sendto( /tmp/zm/zms-955475s.sock ) failed: No such file or directory /usr/share/zoneminder/includes/functions.php 2322
2012-09-18 22:00:03.148691 zma_m1 7299 INF In mode 5/1, warming up zma.cpp 101
2012-09-18 22:00:03.094750 zmdc 7299 INF 'zma -m 1' started at 12/09/18 22:00:03 zmdc.pl
2012-09-18 22:00:03.094740 zmdc 6517 INF 'zma -m 1' starting at 12/09/18 22:00:03, pid = 7299 zmdc.pl
2012-09-18 22:00:03.090820 zmdc 6517 INF Starting pending process, zma -m 1 zmdc.pl
2012-09-18 21:59:58.483210 zmdc 6517 ERR 'zma -m 1' exited abnormally, exit status 11 zmdc.pl
2012-09-18 21:59:58.480519 zma_m1 7292 INF Got signal 11 (Segmentation fault), crashing zm_signal.cpp 73
2012-09-18 21:59:55.733744 web_php 5497 ERR socket_sendto( /tmp/zm/zms-955475s.sock ) failed: No such file or directory /usr/share/zoneminder/includes/functions.php 2322
2012-09-18 21:59:44.947107 zma_m1 7292 INF In mode 5/1, warming up zma.cpp 101
2012-09-18 21:59:44.895550 zmdc 7292 INF 'zma -m 1' started at 12/09/18 21:59:44 zmdc.pl
2012-09-18 21:59:44.895550 zmdc 6517 INF 'zma -m 1' starting at 12/09/18 21:59:44, pid = 7292 zmdc.pl
2012-09-18 21:59:44.892860 zmdc 6517 INF Starting pending process, zma -m 1 zmdc.pl


Wed Sep 19, 2012 3:01 am
Profile

Joined: Tue Sep 18, 2012 2:50 am
Posts: 4
Post Re: How do I run "zmu -d <device> -q -v" against an IP camer
And also:
Attachment:
camera-noimage-view.jpg
camera-noimage-view.jpg [ 16.8 KiB | Viewed 726 times ]



Here's what's going on in Syslog --
have no idea what any of this means...

btw - This was a standard apt-get install packages as requested,
http://www.zoneminder.com/wiki/index.ph ... rom_a_.deb

Did everything in the above, no problems at all...

Sep 18 23:27:10 ub-lenovo web_php[1605]: ERR [Object expected]
Sep 18 23:27:10 ub-lenovo zmwatch[10015]: INF [Restarting analysis daemon for Foscam_FI8918W, time since last analysis 6 seconds (1348025230-1348025224)]
Sep 18 23:27:10 ub-lenovo zmdc[9963]: INF ['zma -m 1' starting at 12/09/18 23:27:10, pid = 10469]
Sep 18 23:27:10 ub-lenovo zmdc[10469]: INF ['zma -m 1' started at 12/09/18 23:27:10]
Sep 18 23:27:10 ub-lenovo zma_m1[10469]: INF [In mode 5/1, warming up]
Sep 18 23:27:11 ub-lenovo web_php[10464]: ERR [Object expected]
Sep 18 23:27:14 ub-lenovo zma_m1[10469]: INF [Got signal 11 (Segmentation fault), crashing]
Sep 18 23:27:14 ub-lenovo zmdc[9963]: ERR ['zma -m 1' exited abnormally, exit status 11]
Sep 18 23:27:20 ub-lenovo zmwatch[10015]: INF [Restarting analysis daemon for Foscam_FI8918W, time since last analysis 6 seconds (1348025240-1348025234)]
Sep 18 23:27:20 ub-lenovo zmdc[9963]: INF ['zma -m 1' starting at 12/09/18 23:27:20, pid = 10479]
Sep 18 23:27:20 ub-lenovo zmdc[10479]: INF ['zma -m 1' started at 12/09/18 23:27:20]
Sep 18 23:27:20 ub-lenovo zma_m1[10479]: INF [In mode 5/1, warming up]
Sep 18 23:27:24 ub-lenovo zma_m1[10479]: INF [Got signal 11 (Segmentation fault), crashing]
Sep 18 23:27:24 ub-lenovo zmdc[9963]: ERR ['zma -m 1' exited abnormally, exit status 11]


Wed Sep 19, 2012 4:29 am
Profile

Joined: Sat Jul 28, 2012 9:30 pm
Posts: 96
Post Re: How do I run "zmu -d <device> -q -v" against an IP camer
You should first try to set up the camera in monitor mode before setting up motion detection. What kind of settings do you have in the camera settings tab (source)? Are resolution settings correct? Don't know if zmu can be used on ip cameras.


Wed Sep 19, 2012 1:42 pm
Profile

Joined: Tue Sep 18, 2012 2:50 am
Posts: 4
Post Re: How do I run "zmu -d <device> -q -v" against an IP camer
I probably confused people by mentioning mocord and modect modes..

I did set the cam up in Monitor first - nothing.

However, I've found a few clues.

I didn't have the cambozola.jar installed.
that certainly changed a few things.

However, I still don't get an image from the camera displayed.
Now, the area on the screen shows the author info for Cambozola, but that's all.

I also didn't have FFMEG listed in options, though it was installed.

I don't know how to test the camera with ffmpeg though - so that may not be working. I can't find the syntax for using ffmpeg with an HTTP URL.


Thu Sep 20, 2012 7:15 pm
Profile

Joined: Sat Jul 28, 2012 9:30 pm
Posts: 96
Post Re: How do I run "zmu -d <device> -q -v" against an IP camer
You should put the camera in monitor mode and check the logs. The zma errors are all related to the motion detection process. Disable motion detection to get rid of those and then start searching for the real problem first. You shouldn't need ffmpeg with foscam, my foscam works well with zm in built functionality. Can you access the camera stream directly from web browser using the same path as is set up in zoneminder? I suggested the problem might be in the camera source settings, have you verified somehow this cannot be the case?


Thu Sep 20, 2012 7:34 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group