View unanswered posts | View active topics It is currently Wed Apr 23, 2014 10:30 am



Reply to topic  [ 17 posts ]  Go to page 1, 2  Next
No Monitor on Motion detect 
Author Message

Joined: Mon Jan 23, 2012 12:00 pm
Posts: 18
Post No Monitor on Motion detect
Hi to all,
after select Modect and clicking on Zones are not showed any image from monitor.

Monitor it's working fine

see attached

Pls help me...


Attachments:
md6.png
md6.png [ 48.41 KiB | Viewed 1007 times ]
Sun Feb 12, 2012 8:42 pm
Profile

Joined: Wed Dec 02, 2009 10:55 pm
Posts: 661
Location: Spain
Post Re: No Monitor on Motion detect
Search cambozola
viewtopic.php?f=21&t=17586&hilit=mootools

_________________

miniITX system (5 IPCams) (ZM1.25)
testing miniITX system (1 Aircam IPCAM) (ZM1.27)


Sun Feb 12, 2012 8:53 pm
Profile

Joined: Mon Jan 23, 2012 12:00 pm
Posts: 18
Post Re: No Monitor on Motion detect
What means "cambozola"


Sun Feb 12, 2012 9:03 pm
Profile

Joined: Wed Dec 02, 2009 10:55 pm
Posts: 661
Location: Spain
Post Re: No Monitor on Motion detect
Read the link I posted and check your system.

_________________

miniITX system (5 IPCams) (ZM1.25)
testing miniITX system (1 Aircam IPCAM) (ZM1.27)


Mon Feb 13, 2012 6:10 am
Profile

Joined: Mon Jan 23, 2012 12:00 pm
Posts: 18
Post Re: No Monitor on Motion detect
I have modified the file
'/usr/share/zoneminder/skins/classic/includes/functions.php' in this way :



Code:
<script type="text/javascript" src="../javascript/mootools/mootools-core-nc.js"></script>
<script type="text/javascript" src="../javascript/mootools/mootools-more-nc.js"></script>


now I have 4 pointer in for each corner but no image...


Attachments:
md7.png
md7.png [ 53.35 KiB | Viewed 982 times ]
Mon Feb 13, 2012 9:19 pm
Profile

Joined: Wed Dec 02, 2009 10:55 pm
Posts: 661
Location: Spain
Post Re: No Monitor on Motion detect
Getting closer...Have your system the default directories (/usr/share/zoneminder/events-images-temp)?. Have you moved the default location?. Check the ownership and permissions of the directories.
Hope it helps!

_________________

miniITX system (5 IPCams) (ZM1.25)
testing miniITX system (1 Aircam IPCAM) (ZM1.27)


Mon Feb 13, 2012 11:02 pm
Profile

Joined: Mon Jan 23, 2012 12:00 pm
Posts: 18
Post Re: No Monitor on Motion detect
Have your system the default directories (/usr/share/zoneminder/events-images-temp)?: yes I have...linked see below
massimiliano@maxnb:~$ ls -la /usr/share/zoneminder
totale 64
drwxr-xr-x 13 root root 4096 2012-01-21 19:28 .
drwxr-xr-x 356 root root 12288 2012-01-23 11:25 ..
drwxr-xr-x 2 root root 4096 2012-01-21 19:28 ajax
lrwxrwxrwx 1 root root 17 2012-01-21 19:28 cgi-bin -> ../../lib/cgi-bin
drwxr-xr-x 2 root root 4096 2012-01-21 19:28 css
drwxr-xr-x 2 root root 4096 2012-01-21 19:28 db
lrwxrwxrwx 1 root root 28 2012-01-21 19:28 events -> /var/cache/zoneminder/events
drwxr-xr-x 2 root root 4096 2012-01-21 19:28 graphics
lrwxrwxrwx 1 root root 28 2012-01-21 19:28 images -> /var/cache/zoneminder/images
drwxr-xr-x 2 root root 4096 2012-01-21 19:28 includes
-rw-r--r-- 1 root root 3717 2011-01-17 12:31 index.php
drwxr-xr-x 2 root root 4096 2011-01-17 12:31 js
drwxr-xr-x 2 root root 4096 2012-01-21 19:28 lang
drwxr-xr-x 4 root root 4096 2012-01-21 19:28 skins
drwxr-xr-x 2 root root 4096 2011-01-17 12:31 sounds
lrwxrwxrwx 1 root root 26 2012-01-21 19:28 temp -> /var/cache/zoneminder/temp
drwxr-xr-x 2 root root 4096 2011-01-17 12:31 tools
drwxr-xr-x 2 root root 4096 2011-01-17 12:31 views
massimiliano@maxnb:~$



Have you moved the default location? What have I to do to move the default location ?
Check the ownership and permissions of the directories: what directories have i to check...

Be patient for my not experience...


Tue Feb 14, 2012 7:04 am
Profile

Joined: Wed Dec 02, 2009 10:55 pm
Posts: 661
Location: Spain
Post Re: No Monitor on Motion detect
Try changing the ownership from root to www-data:

Stop zoneminder, then:
Code:
 chown -R www-data:www-data /usr/share/zoneminder/events
 chown -R www-data:www-data /usr/share/zoneminder/images
 chown -R www-data:www-data /usr/share/zoneminder/temp


Restart zoneminder, check if image appears in the zone settings.

_________________

miniITX system (5 IPCams) (ZM1.25)
testing miniITX system (1 Aircam IPCAM) (ZM1.27)


Tue Feb 14, 2012 9:11 am
Profile

Joined: Mon Jan 23, 2012 12:00 pm
Posts: 18
Post Re: No Monitor on Motion detect
after changing the owner to www-data no image on zone and also the monitor it's not showing anything, so i return to root owner..


Tue Feb 14, 2012 9:51 pm
Profile

Joined: Fri Aug 12, 2011 9:35 pm
Posts: 32
Post Re: No Monitor on Motion detect
I had a similar issue with my zones. I had to run make install again from the ZM directory to get the ability to have the zones again. I word of caution, you will have to recreate all your cameras. Make sure you have all the setting recorded first. Also back up any pictures or videos you want to save first.
Good luck!


Tue Feb 14, 2012 11:19 pm
Profile

Joined: Mon Jan 23, 2012 12:00 pm
Posts: 18
Post Re: No Monitor on Motion detect
sorry ...where is the zm directory to remake ...
I have installed directly fron sudo apt-get install....


thanks


Wed Feb 15, 2012 10:19 pm
Profile

Joined: Thu Jun 03, 2010 7:43 am
Posts: 36
Post Re: No Monitor on Motion detect
Hello

I have exactly the same problem.
http://www.zoneminder.com/forums/viewtopic.php?f=21&t=18809

sudo apt-get remove zoneminder and afterwards
sudo apt-get install zoneminder

did not really help!


Sun Feb 19, 2012 8:45 am
Profile

Joined: Mon Jan 23, 2012 12:00 pm
Posts: 18
Post Re: No Monitor on Motion detect
I have tried to remove and install again but not nothing successful, ..
now I am trying with new version 1.25.0, but i am not lucky, I have configured, compiled and install
but it's not running...I have to a open a new post


Mon Feb 20, 2012 11:37 am
Profile

Joined: Thu Jun 03, 2010 7:43 am
Posts: 36
Post Re: No Monitor on Motion detect
Any news how to solve it? Seems to be a problem with 10.04... Mainly...


Sun Feb 26, 2012 9:20 am
Profile

Joined: Thu Jun 03, 2010 7:43 am
Posts: 36
Post Re: No Monitor on Motion detect
Is here no one that can help? Also compiling 1.24.4 does not work see other new thread!

Why is this SW sooo complex?


Sun Feb 26, 2012 5:10 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 17 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group