View unanswered posts | View active topics It is currently Thu Oct 23, 2014 7:39 am



Reply to topic  [ 2 posts ] 
Axis M3114 works 
Author Message

Joined: Mon Apr 23, 2012 6:15 pm
Posts: 9
Post Axis M3114 works
I have 3 Axis M3114 cameras and I have them all working with h264 streaming with no errors!

My setup:

ubuntu server 12.04 LTS 32-bit

You *must* use Original ffmpeg. The libav ffmpeg that ubuntu supplies if you do apt-get install zoneminder will NOT work. It will appear to work for about 10-30 seconds, but then you'll get garbled data from the cameras into zoneminder. This took me forever to find!

The steps to get it installed:

1. Install the ubuntu-server from a CD. When it's time to pick what features you want, ONLY choose OpenSSH server. Do not install anything else.

2. Once the server is up and you can login, make sure you use the Jon Severinsson PPA to get the Original ffmpeg, before you do anything else. This way when you install zoneminder, it will use this and not attempt to grab the libav version of the packages. If you already installed libav, you will need to uninstall ALL of it in order for this to work. I had a hard time doing this, so I just wiped my server over and re-installed.

Here's what you type to get the Original ffmpeg installed:

Code:
sudo apt-get install python-software-properties
sudo add-apt-repository ppa:jon-severinsson/ffmpeg
sudo apt-get update
sudo apt-get install -V ffmpeg


3. Now you can install zoneminder from packages. ubuntu-server 12.04 installs 1.25.0 currently.

Code:
sudo apt-get install zoneminder


4. I setup a video streaming profile for each camera so I could reduce the image size to 800x600. But you can choose any size you want if you have disk space and cpu to handle it. The settings I chose are: h264, GOV Length 20, Variable Bit rate. In my example the stream profile is named "zmprofile".

5. Configure Zoneminder options. On the Images tab, set the following:

Code:
FFMPEG_INPUT_OPTIONS: "-rtsp_flags filter_src -an"
FFMPEG_OUTPUT_OPTIONS:


4. Configure Zoneminder as usual. When it comes time to configure the cameras, choose the Axis h264 ffmpeg preset.

In the Source Path field, is where you put the URL that ffmpeg uses. Here's what I use:

Code:
rtsp://user:password@camera.mynet/axis-media/media.amp?streamprofile=zmprofile


In this case, replace user with your camera's username, password with the password, camera.mynet with the IP address or hostname of your camera.

5. You will likely need to stop and then stop Zoneminder for all of the settings to take, not just "restart".


Sat Apr 28, 2012 6:19 pm
Profile

Joined: Thu Jul 06, 2006 3:27 pm
Posts: 341
Post Re: Axis M3114 works
Thanks for the update Cambot - hopefully it'll be useful to other ubuntu users. Surprised about the ffmpeg bit though, not heard of that before.


Sun Apr 29, 2012 7:25 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group