View unanswered posts | View active topics It is currently Thu Oct 23, 2014 4:45 am



Reply to topic  [ 62 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next
Airlink101 SkyIPCam 747W - Working 
Author Message

Joined: Fri Aug 07, 2009 4:11 pm
Posts: 1
Post Cant get it to work
I bought the 747 at Fry's for $99.00. Its the wired version. Anyways I can see it in the browser using http://user:password@xx.xx.xx.xx/cgi/jpg/image.cgi. I put in for host username:password@xx.xx.xx.xx, port 80, and for path /cgi/jpg/image.cgi. I set the resolution to 640x480. I am using Ubuntu 9.04 and Zoneminder 1.23.3. All I get is a black picture. Any help would be appreciated. Thanks in advance.


Fri Aug 07, 2009 6:40 pm
Profile

Joined: Fri Aug 21, 2009 4:33 am
Posts: 2
Location: Frisco, TX
Post TRENDNet TV-IP422(w) MJPEG Support?
I saw in this thread that the TRENDNet firmware had been updated to correct the MIME Type issuse in the MJPEG feed. I'm running the latest version of the firmware (1.0.0 build: 71) on a IP422W without success. Has anyone had success with a different firmware version?

Quote:
The trendnet version of these cameras have a new firmware that uses a Zoneminder supported mjpg stream so you might want to look at the trendnet cameras instead.


Fri Aug 21, 2009 4:41 am
Profile

Joined: Fri Aug 21, 2009 7:04 pm
Posts: 5
Post Re: TRENDNet TV-IP422(w) MJPEG Support?
bill.schuller wrote:
I saw in this thread that the TRENDNet firmware had been updated to correct the MIME Type issuse in the MJPEG feed. I'm running the latest version of the firmware (1.0.0 build: 71) on a IP422W without success. Has anyone had success with a different firmware version?


Note that there are two different MJPEG urls now, at least on my AIC500 camera.

mjpeg.cgi - the 'special' format with embedded camera info.
mjpg.cgi - the 'standard' MJPEG format

I haven't tried video with Zoneminder yet, but with the new firmware both Firefox and MythTV can stream live video using the mjpg.cgi URL.


Fri Aug 21, 2009 7:07 pm
Profile

Joined: Fri Aug 21, 2009 4:33 am
Posts: 2
Location: Frisco, TX
Post Re: TRENDNet TV-IP422(w) MJPEG Support?
MarkG wrote:
mjpg.cgi - the 'standard' MJPEG format

I haven't tried video with Zoneminder yet, but with the new firmware both Firefox and MythTV can stream live video using the mjpg.cgi URL.


The mjpg.cgi URL worked perfect in ZM 1.24.1. Thanks for the tip!


Sat Aug 22, 2009 5:00 am
Profile

Joined: Mon Nov 27, 2006 12:16 am
Posts: 17
Post Re: TRENDNet TV-IP422(w) MJPEG Support?
bill.schuller wrote:

The mjpg.cgi URL worked perfect in ZM 1.24.1. Thanks for the tip!


I just wish I could flash the Airlink-777W camera with the Trendnet firmware...


Sun Aug 23, 2009 6:58 pm
Profile

Joined: Fri Aug 21, 2009 7:04 pm
Posts: 5
Post Re: TRENDNet TV-IP422(w) MJPEG Support?
PRDR wrote:
I just wish I could flash the Airlink-777W camera with the Trendnet firmware...


Have you tried bugging their support guys to release a firmware upgrade, as they already have for the AIC500? The code exists and they're clearly capable of getting it, so if it means more sales for them...


Sun Aug 23, 2009 7:44 pm
Profile

Joined: Mon Nov 27, 2006 12:16 am
Posts: 17
Post Re: TRENDNet TV-IP422(w) MJPEG Support?
MarkG wrote:
PRDR wrote:
I just wish I could flash the Airlink-777W camera with the Trendnet firmware...


Have you tried bugging their support guys to release a firmware upgrade, as they already have for the AIC500? The code exists and they're clearly capable of getting it, so if it means more sales for them...


You're right. I had given up on support guys, but it's worth a try...

DONE, let's see if they care...



:oops: Guys, I feel really stupid... Right after writing to the support ppl, I tried the url /cgi/mjpg/mjpg.cgi, and guess what, it worked! It seems to have always been there. Actually, I tried it with an Encore camera which has pretty much the same web interface as the 777W, and it worked too... So, we have always had a working mjpeg stream... :lol:

I hope my e-mail at least helps on the noisy-audio-over-wireless issue...


Mon Aug 24, 2009 1:43 am
Profile

Joined: Fri Jul 17, 2009 2:19 am
Posts: 3
Post Re: TRENDNet TV-IP422(w) MJPEG Support?
MarkG wrote:
PRDR wrote:
I just wish I could flash the Airlink-777W camera with the Trendnet firmware...


Have you tried bugging their support guys to release a firmware upgrade, as they already have for the AIC500? The code exists and they're clearly capable of getting it, so if it means more sales for them...



Beware, the Airlink tech support folks, while they try to help, have no NEW firmware to offer at all--it is totally lame. The Trendnet version of the AICN777W is up to FW rev like .71, versus .19 shipping, and the .25 does help--but even Airlink will say they wont support you if you goto the .25 firmware from page three of this forum. Basically really really crappy support. this camera is oem'ed by so many manufacturers i wish the oem would just step up and help us. it REALLY STINKS!

Definitely bug them for a firmware update--bug them on one of the wireless issues or something. They stonewalled me and at least one other guy, but there's strength in numbers.

I too REALLY WISH I COULD FLASH THE TRENDNET FIRMWARE ONTO MY AICN77W. The trendnet camera is so much better-supported. I wish someone would hack/reverse engineer a way to do this...


Wed Aug 26, 2009 3:39 am
Profile

Joined: Sat Aug 29, 2009 5:40 pm
Posts: 1
Post Firmware with telnet for AICN747[W]
Given the GPL source and the 1.0.0-24 firmware now posted on the www.airlink101.com website, it is easy to hack up a version that enables telnet. The telnetd server executable is already present. All you need to do is activate it in the /etc/rc.d/init.d/daemon.sh script.

I posted the details and a new firmware on my yahoo group:
http://tech.groups.yahoo.com/group/mytinker/

I can report that it indeed works in my AICN747W IP camera.
It should also be possible to install other programs, e.g. dropbear. Unfortunately there is little persistent storage.
As far as I can see the device maps its root file system in a ramdisk. It doesn't use nvram.

Cheers,
Geert


Sat Aug 29, 2009 5:50 pm
Profile
User avatar

Joined: Thu Oct 18, 2007 2:55 pm
Posts: 568
Location: Shiloh, IL
Post 
I just wanted to say thank you to all those that have participated in this thread.... with the info posted here I was able to get my Airlink 777W working with Zoneminder at max resolution and frame rate. Pan/Tilt controls work as well.

http://www.zoneminder.com/forums/viewto ... ht=airlink


Fri Sep 04, 2009 1:15 pm
Profile

Joined: Mon Dec 10, 2007 6:53 pm
Posts: 194
Location: San Jose, CA
Post 
I installed the firmware update on Airlink's website on my 747W and Zoneminder (1.24.2) was able to access the camer's mjpeg stream when I set "Remote Host Path" to /cgi/mjpg/mjpg.cgi

I'm getting ~24-27 fps on the camera through Zoneminder now.




Airlink the gave the download an odd name of "AICN747W Original Firmware". It made me wonder if it was the firmware the camera originally shipped with. After I downloaded the zip file and open it, I saw the newer firmware version number of 1.0.0-24.


Fri Sep 04, 2009 6:49 pm
Profile WWW

Joined: Fri Sep 11, 2009 7:50 pm
Posts: 3
Post Airlink101 747W and 500 no workie
Hi All,
I've been banging my head against a wall on this one, even after reading and applying all of the great info found in this forum. I have both a 500 and a 747W that I am trying to link with ZM and still have no picture.
I am running Ubuntu v9.04 (JJ) and ZM v1.23.3. I am able to view stills on either camera using "<IPaddress>/cgi/jpg/image.cgi" using firefox on the server, but nothing through Zoneminder. I even flashed the 747 firmware to the latest version (24). Here are my settings:


Hostname = "admin:admin@192.168.0.100"
Host port = "80"
Host path = "/cgi/jpg/image.cgi"
24 bit colour
Width = 640
Height = 480

Under Options/Network I have:

Option remote = yes
netcam regexps = yes
http version = 1.1
http VA = ZoneMinder
http timeout = 2500

I am at a loss and am considering bumping Ubuntu back to 8.04, but that's a buch of work I would rather not do if possible. Any help or suggestions would be greatly appreciated.


Fri Sep 11, 2009 8:22 pm
Profile
User avatar

Joined: Thu Oct 18, 2007 2:55 pm
Posts: 568
Location: Shiloh, IL
Post 
Change your host path to what is shown in the thread previously mentioned:
http://www.zoneminder.com/forums/viewto ... ht=airlink

Your camera programs the same in mjpeg mode as the 777.

BTW: the 500 should program the same as well. I just bought a 500W and have it working great.


Fri Sep 11, 2009 9:57 pm
Profile

Joined: Fri Sep 11, 2009 7:50 pm
Posts: 3
Post 
Knnniggett,
I tried the settings that you posted but perhaps I am suffering from newbieism and cannot find the controls for changing the settings for remote protocol or remote method. I looked through the camera settings as well as the options page. Do I need to go into terminal and try to muck with it there?
Perhaps I am missing a plugin..I thought I read somewhere that cambozola.jar is included in the zoneminder 1.23.3 package so I didn't specifically install it. I did install ffmpeg so that's not the issue.

Remote Protocol: HTTP
Remote Method: Simple

\Remote Host Name: {username}:{password}@{camera ip}
Remote Host Port: 80
Remote Host Path: /cgi/mjpg/mjpg.cgi
Remote Image colors: 24 bit
Capture Width: 640
Capture Height: 480

I also flashed the 500 firmware to the latest (B25) so the nonstandard mjpeg shouldn't be an issue.

Thank you very much for your help on this issue.


Fri Sep 11, 2009 11:03 pm
Profile
User avatar

Joined: Thu Jan 25, 2007 5:51 pm
Posts: 44
Location: San Jose, CA
Post 
timcraig wrote:
I installed the firmware update on Airlink's website on my 747W and Zoneminder (1.24.2) was able to access the camer's mjpeg stream when I set "Remote Host Path" to /cgi/mjpg/mjpg.cgi

I'm getting ~24-27 fps on the camera through Zoneminder now.




Airlink the gave the download an odd name of "AICN747W Original Firmware". It made me wonder if it was the firmware the camera originally shipped with. After I downloaded the zip file and open it, I saw the newer firmware version number of 1.0.0-24.


Thanks for the good news timcraig!

It's been nearly a year since I first bugged Airlink about the broken mjpeg stuff. Better late then never, I guess...


Fri Sep 11, 2009 11:29 pm
Profile YIM WWW
Display posts from previous:  Sort by  
Reply to topic   [ 62 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group